Docker Community Forums

Share and learn in the Docker community.

Unable to locate package docker-scan-plugin


I faced a problem about installing docker with curl from “”.
Operating System: Ubuntu 18.04.5 LTS
Docker Server Version: 20.10.8

I have a Gitlab instance and a complete CI/CD pipeline that worked in the past but now I get this error:

Step 7/15 : RUN curl -sSL | sh
 ---> Running in ---------------------
# Executing docker install script, commit: -----------------------------------------
    This Linux distribution (debian stretch) reached end-of-life and is no longer supported by this script.
    No updates or security fixes will be released for this distribution, and users are recommended
    to upgrade to a currently maintained version of debian.
Press Ctrl+C now to abort this script, or wait for the installation to continue.
+ sh -c apt-get update -qq >/dev/null
+ sh -c DEBIAN_FRONTEND=noninteractive apt-get install -y -qq apt-transport-https ca-certificates curl >/dev/null
debconf: delaying package configuration, since apt-utils is not installed
+ sh -c curl -fsSL "" | gpg --dearmor --yes -o /usr/share/keyrings/docker-archive-keyring.gpg
+ sh -c echo "deb [arch=amd64 signed-by=/usr/share/keyrings/docker-archive-keyring.gpg] stretch stable" > /etc/apt/sources.list.d/docker.list
+ sh -c apt-get update -qq >/dev/null
+ sh -c DEBIAN_FRONTEND=noninteractive apt-get install -y -qq --no-install-recommends  docker-ce-cli docker-scan-plugin docker-ce >/dev/null
E: Unable to locate package docker-scan-plugin
The command '/bin/sh -c curl -sSL | sh' returned a non-zero code: 100
ERROR: Job failed: exit status 1

I tried to install the plugin manually, update the packages etc. but nothing has worked. Other interesting thing (maybe normal I don’t know) that every link points to debian and not ubuntu, however the system is ubuntu.

Do you have any idea?

Seems like your base image is a debian strech image, which according the warning is not longer supported by the convenience script.

Can you share the FROM instruction of your Dockerfile?

1 Like

Thank you for your answer and sorry for the late reply. The problem was really an old base image (from python:3.7.1) but that was unclear until you mentioned the base image and I looked up the reference.

Problem solved by changing It to python:3.7.