Docker Community Forums

Share and learn in the Docker community.

Debian on ARMv7 - ERROR: ELF load command alignment not page-aligned


#1

Hi,

Issue type: Error from Debian docker image
OS Version/build: Linux MyCloud 3.10.39 #1 SMP Fri Aug 17 18:23:06 CST 2018 2014T30p5 Build-git435df54 armv7l GNU/Linux
App version: Docker version 18.06.0-ce, build / Debian:latest
Steps to reproduce: Build image with MariaDB / PostgreSQL installed

When using the Debian:Latest image as a base I am experiencing this message when certain packages are installed:

error while loading shared libraries: libsystemd.so.0: ELF load command alignment not page-aligned

I’m pretty new to Docker and on my Western Digital EX4100 NAS - which is powered by a Marvell Armada ARMv7 processor - I’ve been trying to build a docker-based OwnCloud instance. Why? Because the official image is not yet provided for this architecture.

So far I’ve managed to create a configurable Docker OwnCloud image that incorporates Certbot, but although functionally it all works OK I get this same error when installing the required packages using apt-get: It happens from when the php7.0 package is installed.

The same error also showed when I tried to apt-get install mariadb-server and when I tried to install Postgresql.

I have provided a Dockerfile and the output from building OwnCloud, which provides probably the most spectacular example of this problem.

I will greatly appreciate any help because this appears to be breaking both database installs on my ARMv7 platform, as well as preventing logging from happening inside my OwnCloud image.

Many thanks :smile:


#2

Hmmm interesting…

Running xtremxpert/rpi-mariadb gives this error:

docker container logs 1d1deac16ca9

runtime: kernel page size (32768) is larger than runtime page size (4096)


Building a custom mariadb instance based on alpine linux works perfectly, no problems with page size. There is a problem with the db being read only (similar to: ERROR 1036 (HY000): Table ‘oc_abcd’ is read only), but that looks like a whole different issue,

A custom build of OwnCloud based on alpine linux also works perfectly, with respect to the above.