Disable Client Experimental Features on Linux

Hi, I would like to turn off the Client Experimental Features:

I have already tried to set the config.json in the ~/.docker directory to:

{
    "experimental":  "disabled"
}

And I did the same in the /etc/docker/daemon.json, but that diddn’t helped either.

Any ideas?

Hi

That configuration file is only for the docker client, where you can set stuff like format of your output, or proxy settings.

The one you want to add it to is: /etc/docker/daemon.json, remember to restart docker afterwards

Hi, thanks for your answer. As mentioned I tried this already and restarted docker aswell, that diddn’t worked…

My /etc/docker/daemon.json looks as follows:

{
    "experimental": false
}

And I restarted docker with > sudo service docker restart

Sorry, just woke up, you’re right.

In the engine part it does state “false”, but not in the client config.

In your ~/.docker/config.json, have you tried setting it to “false” where you currently have “disabled” ?

Just tried it, doesn’t work either…

Okay, after reading a bit, it dosnt seem like its possible to disable it anymore:

// Deprecated: experimental features are now always enabled in the CLI