Docker Community Forums

Share and learn in the Docker community.

Docker CE with RHEL 7.6 - Container not running

Hi, new to Docker community and having problem with setting up the Docker on my laptop
using RHEL 7.6.

Tried with both Docker CE and EE version, they installed correctly, however when I run the command

docker run hello-world

it just keeps on running, no output. The container seems to be created but it never runs:

docker container ls -all
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
b552308a64f0 hello-world “/hello” 19 hours ago Created heuristic_keldysh

Here is the docker info:
docker info
Containers: 4
Running: 0
Paused: 0
Stopped: 4
Images: 2
Server Version: 18.09.2
Storage Driver: overlay2
Backing Filesystem: extfs
Supports d_type: true
Native Overlay Diff: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: bridge host macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 9754871865f7fe2f4e74d43e2fc7ccd237edcbce
runc version: 09c8266bf2fcf9519a651b04ae54c967b9ab86ec
init version: fec3683
Security Options:
seccomp
Profile: default
fips
Kernel Version: 3.10.0-957.5.1.el7.x86_64
Operating System: Red Hat Enterprise Linux Workstation 7.6 (Maipo)
OSType: linux
Architecture: x86_64
CPUs: 8
Total Memory: 30.95GiB
Name: mycomputer
ID: VCN3:NAEH:6ECC:HMBK:NPUN:AAOA:SZDJ:GFKY:RKKG:44LR:DKIQ:XVAM
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Labels:
com.docker.security.seccomp=enabled
com.docker.security.fips=enabled
Experimental: false
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false
Product License: Unlicensed Enterprise Engine

Anyone else have the same issue and if you can help me to find the solution.
Thanks

Isn’t hello-world just a “one-shot” container that prints output to stdout and the quits?
This would explain why it is not running…

Also, how did you make Docker-CE running on RHEL7.6?

Today I ran a complex stack with Docker-EE on RHEL7.6. It works much the same, as it did with RHEL7.5 before. Though, my machines are not yet on docker engine 18.09.2.

yes, it is a one shot container… however it should give some output. The command just keeps running…
Tried both the Docker CE & EE version, behavior remains the same.