Docker Community Forums

Share and learn in the Docker community.

docker commands running slow


(Laubnyc) #1

All docker commands are running slow (e.g., ps, logs)

Docker Toolbox
Windows 10
VirtualBox default set to 2 CPUs

I’m on a weak wi-fi network, but don’t need to download anything. My app itself is running fine.

$ docker -D info
Containers: 17
Running: 14
Paused: 0
Stopped: 3
Images: 60
Server Version: 18.03.0-ce
Storage Driver: aufs
Root Dir: /mnt/sda1/var/lib/docker/aufs
Backing Filesystem: extfs
Dirs: 159
Dirperm1 Supported: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: bridge host macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: cfd04396dc68220d1cecbe686a6cc3aa5ce3667c
runc version: 4fc53a81fb7c994640722ac585fa9ca548971871
init version: 949e6fa
Security Options:
seccomp
Profile: default
Kernel Version: 4.9.89-boot2docker
Operating System: Boot2Docker 18.03.0-ce (TCL 8.2.1); HEAD : 404ee40 - Thu Mar 22 17:12:23 UTC 2018
OSType: linux
Architecture: x86_64
CPUs: 2
Total Memory: 9.514GiB
Name: default
ID: CEUZ:WW6S:6CZV:T2Z7:3NII:JFDV:MEEW:KGJA:HN4V:RIKR:VUM3:QPNG
Docker Root Dir: /mnt/sda1/var/lib/docker
Debug Mode (client): true
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Labels:![2018-03-23%2014_20_02-default%20-%20Settings|672x500]
provider=virtualbox
Experimental: false
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false

Thanks!


(Bantl23) #2

Hi, I have the exact same issue. Did you happen to resolve this? I’m at a loss. I think it’s somehow related to networking because if log into the boot2docker vm the responses are quick.

> docker-machine ssh default
> docker ps -a

Have you tried doing that?


(Caseychamberlain) #3

Same issue here. Even docker -v consistently takes 17 seconds when my host Windows 10 laptop is connected to the network via Wifi. As soon as I disconnect from that wireless network, or turn-off Wifi, the operations are instant. Even the Tray Icon takes 15 seconds for the menu options to even come up. Same behavior for both Linux container or Windows container mode.

An example …

PS C:\dev> get-date;docker -v;get-date

Saturday, September 8, 2018 8:35:40 AM
Docker version 18.06.1-ce, build e68fc7a
Saturday, September 8, 2018 8:35:56 AM

RESOLVED
This posting on github pointed me to the solution. As noted above, I originally thought it was due to me being on wireless because the commands would execute quickly when I disconnected wireless. I finally had a chance to connect to my ethernet from home and had the same problem.

After the github posting, I connected to corp via our VPN and the Docker commands then executed MUCH more quickly. There is still a minor one second-ish delay, probably due to latency of the domain controller calls, but that’s all.