Docker compose qbittorrent settings are not saved after restart


I have migrated a linuxserver/qbittorrent container from a proxmox lxc to a VM . Before the migration it was working fine, saved the changes I made in the webui, but now I cant make it save any changes. Other containers I migrated seems to work fine (I did them now and I migrated qbittorrent a few days ago, but actually I didnt even copy the config folder for qbittorrent so that created itself).

The user that runs qbittorrent-nox is the owner of the config files and has permissions, tried to change the permission to even 777, but that didnt work either. If I manually edit the config file with my user than that is saved properly.
When I save the config in the webui it seems like it saves it and it works until I restart the container.
I tried checking the logs in the webui and the logs of the container, but I dont see anything pop up when I make the changes.
I even tried changing PUID and PGID in the compose file to 0 to match the root user, but even that didnt work.

Does anybody have any idea what could cause this or what could I check?

Until you restart or recreate? Restart would not delete anything. Recreating it would. Please, show your compose file, because it is hard to point out any mistakes without it.

What do you mean by migration? I don’t use proxmox, but the environment shouldn’t affect whether your files are saved or not, unless you save the files in a tmpfs filesystem in the memory. Make sure the files are saved on a persistent storage.

I meant recreate, excuse me If i mix up things, I am not that experiences with docker.

    container_name: qbittorrent
    network_mode: "service:gluetun"
      - PUID=1000
      - PGID=1000
      - TZ=Etc/UTC
      - WEBUI_PORT=8080
      - TORRENTING_PORT=22649
      - /home/renato/docker/qbittorrent/qbittorrent-config:/config
      - /mnt/tmpseed:/downloads
      - /mnt/MediaContent/Downloads:/autoDownloads
    restart: unless-stopped
        condition: service_healthy

Migration in this case was just copy pasting config and changing the paths for the volumes. For this container I only copyd the compose file, so not even the configs.
All of my docker configs are stored in a subdirectory of my home folder, so I guess that should not be an issue.

And where should that config be? In /config in the container? Have you checked if it is there? And on the host?

Note: I know the image description on Docker Hub shows using the latest tag, but it is not recommended. If there is a bug in a new version, your image could work on one machine because the latest tag was already available locally, but on another machine you get a completely different image.

The config files are in there on both host and container. I checked both the old and new containers config folders and I noticed that on the old host its going like : container folder/config/qbittorrent/
on the new host i renamed config to qbittorrent-config and the structure was the same and the configs were actually saved correctly, but there was an extra set of config a folder above aswell and that config was used when the container was recreated.

So I changed the compose file to just /config on the host, deleted the extra set of configs and now its working perfectly.

I also set the tag to a fixed version.

Thank you very much for your help!!