Docker files and folders in a mounted volume do not show up outside docker

I’ve mounted /usr/local/appdata/sonarr as /config, I’ve also set perms to 777 and made use that 1000 is the owner. However, when I launch the docker it creates files in /config but they do not show up in the actual location. Furthermore, all files are wiped from /config when I restart the machine.

The issue is resolved if I place /config somewhere under /home/******/…, but I’d like to use my SSD and this solution would force me to use my hard disk for configs.

I’ve also tried other directories like /usr/appdata but those haven’t worked either.

I’m using the following yml, any help is really appreciated!

sonarr:
    image: lscr.io/linuxserver/sonarr:latest
    container_name: sonarr
    environment:
      - PUID=1000
      - PGID=1000
    volumes:
      - /usr/local/appdata/sonarr:/config:rw
      - /home/******:/sonarr-media
    ports:
      - 8989:8989
    restart: unless-stopped

Container, not Docker… That is th software.

If you really use Docker Desktop as the category suggest, you need to share the host folders with Docker Destkop. Otherwise you will mount folders from the vitual machine of Docker Desktop, not the host. Go to settings » Resources » File sharing.

Home is shared by default