Docker Compose Translation ~ "-d" and "-it powershell"

Okay, I figured out a solution/workaround.

Turns out that you can just use ‘’-d’’ as part of ‘‘docker up’’, same as with ‘‘docker run’’, and that resolved the first part of this issue. It might be obvious once you know it, but I’m still new at this.

The second part was more complicated, and the way I resolved it is more of a workaround. If anyone has a better solution to this, please let me know.

The heart of the issue was that the ‘‘projectportal’’ didn’t have a ‘‘CMD’’ command inside its Dockerfile, and thus needed to be executed with something like it (I’m still not 100% certain how it works). At first I tried numerous ways of getting the actual Project Portal Apache server to work (see Run apache in Docker Windows container using parameters), but after that didn’t work, I used the following workaround instead and added the following ‘‘CMD’’ command to my Dockerfile:

CMD ping -t localhost

As I said, I’m pretty certain that’s not the best possible solution, but it works. If anyone knows a better way of doing this, please let me know.

Kira Resari