Docker Community Forums

Share and learn in the Docker community.

Help! How to convert docker run commands to docker-compose.yml?

build
docker

(Adamweb92) #1

Hello!
How can I contvert below “docker run” commands to docker-compose.yml format?

docker network create --subnet=172.20.1.0/24 --ip-range=172.20.1.0/24 --ipv6=false --gateway=172.20.1.1 dockernetwork

docker run -it -d -p 8084:80 -p 8443:443 --net dockernetwork --ip 172.20.1.24 --link mysql5712:mysql5712 -h a2420p5622 -v /webserver/HTDOCS/wordpress:/var/www/vhosts/test1/public --name=a2420-p5622 webserver/a2420-p5622

docker run -it -d -p 3306:3306 --net dockernetwork --ip 172.20.1.252 -h mysql5712 -e MYSQL_ROOT_PASSWORD=rootpass --name=mysql5712 webserver/mysql-5.7.12

Dockerfiles and docker-compose.yml found here:
https://github.com/adampweb/dockerserver
webserver/a2420-p5622 Dockerfile: /apache2420_php5622/a2420/Dockerfile

webserver/mysql-5.7.12 Dockerfile: /mysql/Dockerfile

My docker-compose.yml file (not working): /apache2420_php5622/a2420/docker-compose.yml

output of docker-compose up:
adam@adam-desktop /webserver/BUILD_DOCKER_SERVERS/apache2420_php5622/a2420 $ docker-compose up Creating network "a2420_dockernetwork" with driver "bridge" Creating mysql5712 Creating a2420-p5622 Attaching to mysql5712, a2420-p5622 mysql5712 exited with code 0 ERROR: An HTTP request took too long to complete. Retry with --verbose to obtain debug information. If you encounter this issue regularly because of slow network conditions, consider setting COMPOSE_HTTP_TIMEOUT to a higher value (current value: 60).


(Dvohra) #2

The error message indicates what the fix is,
ERROR: An HTTP request took too long to complete. Retry with --verbose to obtain debug information.
If you encounter this issue regularly because of slow network conditions, consider setting COMPOSE_HTTP_TIMEOUT to a higher value (current value: 60).