Docker Community Forums

Share and learn in the Docker community.

Docker-compose up - Permission denied on most everything


(Rwkrameriii) #1

I created a YML to create a WordPress site based on examples. I’m running on Windows 10 Pro with Docker LCOW enabled. I’ll include the YML below.

In Powershell running as Administrator I execute:

docker-compose up

The database setup returns an error:

db_1         | Initializing database
db_1         | 2018-01-03T17:47:18.089988Z 0 [Warning] Changed limits: max_open_files: 1024 (requested 5000)
db_1         | 2018-01-03T17:47:18.090084Z 0 [Warning] Changed limits: table_open_cache: 431 (requested 2000)
db_1         | 2018-01-03T17:47:18.090276Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
db_1         | 2018-01-03T17:47:18.094354Z 0 [ERROR] --initialize specified but the data directory has files in it. Aborting.
db_1         | 2018-01-03T17:47:18.094572Z 0 [ERROR] Aborting
db_1         |

Then the WordPress setup returns errors (LOTS OF THESE):

....

wordpress_1  | tar: ./wp-includes/js/tinymce/plugins/image/plugin.js: Cannot change ownership to uid 33, gid 33: Permission denied
wordpress_1  | tar: ./wp-includes/js/tinymce/plugins/image/plugin.js: Cannot change mode to rw-r--r--: Permission denied
wordpress_1  | tar: ./wp-includes/js/tinymce/plugins/image: Cannot change mode to rwxr-xr-x: Permission denied
wordpress_1  | tar: ./wp-includes/js/tinymce/plugins/wpeditimage/plugin.min.js: Cannot utime: Permission denied
wordpress_1  | tar: ./wp-includes/js/tinymce/plugins/wpeditimage/plugin.min.js: Cannot change ownership to uid 33, gid 33: Permission denied
wordpress_1  | tar: ./wp-includes/js/tinymce/plugins/wpeditimage/plugin.min.js: Cannot change mode to rw-r--r--: Permission denied
wordpress_1  | tar: ./wp-includes/js/tinymce/plugins/wpeditimage/plugin.js: Cannot utime: Permission denied
wordpress_1  | tar: ./wp-includes/js/tinymce/plugins/wpeditimage/plugin.js: Cannot change ownership to uid 33, gid 33: Permission denied
wordpress_1  | tar: ./wp-includes/js/tinymce/plugins/wpeditimage/plugin.js: Cannot change mode to rw-r--r--: Permission denied
wordpress_1  | tar: ./wp-includes/js/tinymce/plugins/wpeditimage: Cannot change mode to rwxr-xr-x: Permission denied

....

If I uncheck LCOW in Docker and set to Linux containers, I get a different error that seems related to DNS:

PS C:\users\me\Documents\Docker-composer> docker-compose up
Pulling db (mysql:latest)...
ERROR: Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io on [::1]:53: read udp [::1]:44545->[::1]:53: read: connection refused

Of course, I get other errors if I set to Windows container and try this.

I’ve been stuck on this for 4 days now. Uninstall/re-install. So much researching I’m going cross-eyed! Any help would be sweet. Thanks.

The YML I am trying:

version: "3"

services:
   db:
     image: mysql
     volumes:
       - db_data:/var/lib/mysql/data
     restart: always
     environment:
       MYSQL_ROOT_PASSWORD: somewordpress
       MYSQL_DATABASE: wordpress
       MYSQL_USER: wordpress
       MYSQL_PASSWORD: wordpress

   wordpress:
     depends_on:
       - db
     image: wordpress:latest
     ports:
       - "8000:80"
     restart: always
     environment:
       WORDPRESS_DB_HOST: db:3306
       WORDPRESS_DB_USER: wordpress
       WORDPRESS_DB_PASSWORD: wordpress
volumes:
    db_data:

#2

just curious, I had the same error message today, hence how i found this post (but my issue might be different).
Just wanted to say: I do remember i setup the mysql volume as /var/lib/mysql, not /var/lib/mysql/data the other day and it worked for my Drupal site …
https://hub.docker.com/_/mysql mentions the former path as well. Could that be the mysql issue?

For the other user issue, maybe this (set the user/group to 33 in the docker run or the compose file):