Docker Community Forums

Share and learn in the Docker community.

Docker Compose and Windows

docker

(Belthazornv) #1

Hi,

Note: I’m a beginner in docker.

I’ve been playing around with docker for a few days now; but I’m having problems with windows and docker in combination.

Everything works fine, at least I think it does. - I run nginx, php and mysql together; and I can see nginx’s welcome screen. - But… the problem is that I don’t have a permission to write/create directories etc.

Nginx seems to be using the user ‘nginx’ and php using ‘www-data’ from grep on the process.

I think I have to run some sort of script to put the users into the permission groups accordingly although I have no idea how.

This is my docker-compose.yml file:

mysql: image: mysql ports: - "6603:3306" environment: MYSQL_ROOT_PASSWORD: mysql MYSQL_USER: mysql fpm: image: php:7.0.2-fpm volumes: - /c/Users/Administrator/www:/var/www/html ports: - "9000:9000" links: - mysql nginx: image: nginx ports: - "80:80" - "443:443" volumes: - /c/Users/Administrator/www:/var/www/html links: - fpm

If anyone can direct me on what I need to do to get this working or which path I should take; I appreciate it; I tried:

user: “root” on the containers, running chown, etc…


(Dvohra) #2

What is the Windows version. The minimum required is Windows 7+
http://scalarsoftware.com/running-docker-compose-on-windows/