Docker corruption: Power Loss / incorrect shutdown causes Docker to not run properly

I’m running on physical hardware, an edge device, not within a VM.

The OS is Ubuntu Core 15.04.

I had docker with some containers running for days. Over the weekend there was a power loss. Came in, restarted the machine, and tried to access docker commands. Got “Cannot connect to the Docker daemon. Is the docker daemon running on this host?”

I couldn’t figure it out so I ended up wiping the machine and reinstalling docker. It took a little over an hour and I knew I could get it done quickly.

However, as a test I setup another machine which had the same configuration and docker containers running. I pulled the plug on it. Upon reboot, the same cannot connect to the Docker Daemon error has occurred.

Both boxes are identical hardware and software configurations.

For the second box, I did an Uninstall of docker and a reinstall. That fixed it and I didn’t need to wipe everything. But still would like a better solution.

Perhaps there’s a lock file somewhere that doesn’t get reset?

Any help would be appreciated.