[SOLVED] Docker Failed to Start - Docker Desktop for Windows

Issue Type: Docker Failed to Start
OS Version/Build: Windows 10 - 10.0.18363 Build 18363
App Version: “Client: Docker Engine - Community
Cloud integration: 1.0.9
Version: 20.10.5
API version: 1.41
Go version: go1.13.15
Git commit: 55c4c88
Built: Tue Mar 2 20:14:53 2021
OS/Arch: windows/amd64
Context: default
Experimental: true”

Steps to reproduce: Install Docker and try to run Linux Containers

I have Hyper-V checked and WSL installed and running.

On install, Docker fails to start (with Linux Containers). But if I switch to Windows Containers, Docker starts without any problems. I am then unable to switch back to Linux Containers.

I’ve tried uninstalling/reinstalling Docker Desktop but doesn’t affect the outcome.
I have “Use the WSL 2 based engine” checked in the General settings.

It also looks like the “Enable Integration with additional distros:” isn’t working? I see my two distros in the Resources/WSL Integration settings (Ubuntu-18.04 and Ubuntu-20.04) and have both of them checked but when I launch either of them, I get the following message when trying to run “docker version” implying that docker isn’t actually integrated:
“The command ‘docker’ could not be found in this WSL 2 distro.
We recommend to activate the WSL integration in Docker Desktop settings.”

Any help would be greatly appreciated, I’ve been trying to solve this problem for longer than I care to admit…

Crash report - 1A420717-40DD-42DB-9F86-BC539439321E/20210406170617

2 Likes

Docker is running now.

Many different troubleshooting steps were taken but the last steps that I took before it was successful was the following:

  1. Uninstall Docker Desktop
  2. Restart computer
  3. Install Docker Desktop (make sure to install it with admin rights)

I had uninstalled/reinstalled docker many times and separately restarted my laptop many times but am not sure that I followed the exact steps above in that order.

After this, I was also able to enable integration with my additional WSL 2 distros.
Hope this helps someone else who is having a similar problem.

3 Likes

Further testing after running into the same problem after computer restart. I think the problem was actually resolved by running Docker Desktop as Administrator. I think there are some conflicting admin privileges that might be leading to problems? A lot of speculation but hoping this helps someone else.

2 Likes

Worked for me many thanks !

1 Like

im facing an issue plz help me

Start/Enable Hyper-V

1 Like

delete %appdata%\Docker\settings.json and let Docker to create a new one

36 Likes

This worked - thanks!

This fixed the problem for me

This solved it thanks

Right on the point. Great Tip!

This works for me in a well regulated corporation laptop. Thanks!

1 Like

I’ve deleted %appdata%\Docker and %appdata%\Docker Desktop. After that everything is OK for me.

13 Likes

This solution worked for me

Yes, reinstalling and running as administrator worked. thanks.

1 Like

The solution not work for me. i solved by folowing step:

  1. By PowerShell input command: “wsl --install”
  2. Install WSL: https://wslstorestorage.blob.core.windows.net/wslblob/wsl_update_x64.msi
  3. Restart Docker → OK

This one fix it for me too! In my case docker would start but the Docker Desktop app would not come up. After all the above, this was the final piece that fixed it. Thank you.

1 Like

Thanks bro! This one worked for me. It saved my containers! Thanks again. :star_struck:

1 Like

Deleting %appdata%\Docker Desktop didn’t work. I had to delete the entire %appdata%\Docker.

4 Likes

Can confirm flaviocampelo’s solution: deleting these folders got me rid of the error

1 Like