Docker Engine Automatically Getting Stop in Windows 11 Home

Hello everyone,

I am a beginner in Docker. A few weeks ago, I installed Docker and started to learn about Docker. It worked well, and then I paused my learning for a couple of days, and when I am coming back now and starting Docker, the Docker engine is not starting. Can someone please help me to fix the issue?

OS Info
OS Name: Microsoft Windows 11 Home Single Language
Version : 10.0.22621 Build 22621

I ran docker diagnosis I have uploaded the diagnoses to Google Drive and given the link for your view
Docker Diagnose Files: Google Drive

I am thinking the diagnosis tells me there are no distros registered in wsl. and I have tried to install one using wsl --install -d Ubuntu command but I got the output as below:

I have enabled the Virtual Machine in both windows features and BIOS, but the issue is not resolved

Thanks in advance
Rizni

Just to show us it is enabled, please, run the following command in a powershell as administrator:

Get-WindowsOptionalFeature -Online -FeatureName VirtualMachinePlatform

What does it return?

Then I don’t know, but since it is a WSL2 issue, you could also try on the Microsoft forum. If ound this for example

https://answers.microsoft.com/en-us/windows/forum/all/wslregisterdistribution-failed-with-error/5fdd8aa6-175e-4a14-8fe6-07673133fd15

Maybe you already found it and tried everything, but I don’t have a beter idea.