Docker Community Forums

Share and learn in the Docker community.

Docker error Pull request for Gazebo

Hello im new in this Community im Student and need Docker to include Gazebo (3D Software) to run a simulation of a car which is controlled by Matlab.

Because i am using windows our prof said we should use Docker for this application.

i am following the instructions as said but the power shell (which runs as administrator) always gives in the last step this error.
“nable to find image ‘14581:14581’ locally
docker: Error response from daemon: pull access denied for 14581, repository does not exist or may require ‘docker login’: denied: requested access to the resource is denied.
See ‘docker run --help’.”

How can i fix it-
Here ist the description for my experiment

and this is the provided ordner which in the instruction is talked about

ALso the Building for Gazebo worked

is it possible that i need for the last step a permission of my professor , so that i can pull the image or container from his docker hub ?
is that even possible ? please be aware that i am not familiar with these programms

Hopefully someone can help me


Picture of building


picture of the supported gazebo folder

These pictures like eye exeminations but here is the problem:

Your command is wrong. You used -u parameter with docker run without any value. You probably meant -v anyway but it’s not entirely your fault since in your first post on the picture in the 4. step the example is wrong too, although -u has a value there. Since you used an existing parameter without a value the next parameter (-p) became its value so docker thinks the port mapping is the image.

Note: -u is for setting the user which executes the commands inside the container, while -v is for volumes and bind mounts which is what you need.

1 Like

thank you very much for the explanation this worked for me fine now.