Docker Image Error when Trying to Run it


So, I am a complete beginner to using Docker and would appreciate any feedback on an issue I am having with my image.

After trying to run my image inside from the VSC terminal, I am getting an error code: Error response from daemon: pull access denied for alpine-python, repository does not exist or may require ‘docker login’: denied: requested access to the resource is denied.

After going into docker desktop, the image is definitely there.

Note: This image is an image that has already been built for another container.

The error message indicates you tried to pull an image from Docker Hub which didn’t exist. “alpine-python” is an existing image on Docker Hub. If you built it locally, you don’t need to pull it. Docker Desktop can show you local images. Can you show the command that gives the error you shared?

Please use code block for the code using the </> button while you are writing your message.

I was actaully able to get it up and running, though a few things were a bit strange. After finally getting it to run, I noticed that another image was created. After this image image was created, the container was running, but just as with the image, a secondary container was shown. This resulted after selecting to reopen the container through the remote extension within vs code. As I said originally, I am still new and trying to read through all of the documentation to see if this is normal. I will remember to use it next time.

Hi @stochasticnexus - Did you perform any steps to rectify this or no action is done from your side. I am also very new to docker and for me after login to docker hub, i am able to pull and push the images and working fine. Being a new starter of the docker world, want to see any issues faced from starting point.

Regards - San

@sanjeeb2022 - I read the documentation and was able to see that the path in my build command was wrong. Once I rewrote in the terminal from VSC, the image was built successfully, then I ran it. As I stated, I had to write the devcontainer.json and the build file in VSC, though they have already been written for a pre-existing container.