Docker Community Forums

Share and learn in the Docker community.

Docker error with Ubuntu 18.04: Unable to find image 'hello-world:latest' locallylatest: Pulling from library/hello-world

Hello!

I have an error with sudo docker run hello-world.

Unable to find image 'hello-world:latest' locallylatest: Pulling from library/hello-world0e03bdcc26d7: 
Pull completeDigest: sha256:8e3114318a995a1ee497790535e7b88365222a21771ae7e53687ad76563e8e76Status: 
Downloaded newer image for hello-world:latestdocker: Error response from daemon: error creating aufs
 mount to /var/lib/docker/aufs/mnt/6f2ef73fd936d1ffafa9f74a9e5c4c1f84e39c834f353bfecd3058a8118b074a-init:
 mount target=/var/lib/docker/aufs/mnt/6f2ef73fd936d1ffafa9f74a9e5c4c1f84e39c834f353bfecd3058a8118b074a-
init data=br:/var/lib/docker/aufs/diff/6f2ef73fd936d1ffafa9f74a9e5c4c1f84e39c834f353bfecd3058a8118b074a-
init=rw:/var/lib/docker/aufs/diff/5a41b049b22d26cd27db5b028fe3cdb8e6adbbb9ca40cb37ac45f224750a4001=ro+wh,
dio,xino=/dev/shm/aufs.xino: invalid argument.See 'docker run --help'.

I downloaded ubuntu-18.04.4-desktop-amd64 and I ran it with VirtualBox.

When my image is created I did the following steps to install Docker:

$ sudo apt-get remove docker docker-engine docker.io containerd runc
$ sudo apt-get update
$ sudo apt-get upgrade

$ sudo apt-get install \
    apt-transport-https \
    ca-certificates \
    curl \
    gnupg-agent \
    software-properties-common
$ curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -

$ sudo apt-key fingerprint 0EBFCD88

pub   rsa4096 2017-02-22 [SCEA]
      9DC8 5822 9FC7 DD38 854A  E2D8 8D81 803C 0EBF CD88
uid           [ unknown] Docker Release (CE deb) <docker@docker.com>
sub   rsa4096 2017-02-22 [S]

$ sudo add-apt-repository \
   "deb [arch=amd64] https://download.docker.com/linux/ubuntu \
   $(lsb_release -cs) \
   stable"

 $ sudo apt-get update
 $ sudo apt-get install docker-ce docker-ce-cli containerd.io

$ sudo docker run hello-world

When I run the command again I have the error again:

sudo docker run hello-worlddocker: Error response from daemon: error creating aufs mount to /var/lib/docker/aufs/mnt/349d0344aaee6daf7e89bc8771b89c5c0daedd6ae872100030f59bd2f69bf209-init: mount target=/var/lib/docker/aufs/mnt/349d0344aaee6daf7e89bc8771b89c5c0daedd6ae872100030f59bd2f69bf209-init data=br:/var/lib/docker/aufs/diff/349d0344aaee6daf7e89bc8771b89c5c0daedd6ae872100030f59bd2f69bf209-init=rw:/var/lib/docker/aufs/diff/5a41b049b22d26cd27db5b028fe3cdb8e6adbbb9ca40cb37ac45f224750a4001=ro+wh,dio,xino=/dev/shm/aufs.xino: invalid argument.See 'docker run --help'.

I don’t understand what can be the problem? I read a LOT of forums and questions on Internet but none helped me. Can you guys please help me :open_mouth:

Docker is well installed, because when I put docker --version I get: Docker version 19.03.8, build afab8b7b0