Docker Community Forums

Share and learn in the Docker community.

Docker for Mac - Additional restart required after upgrade


(Jesse Adametz) #1

Expected behavior

When prompted for an upgrade and completing the process Docker should restart it self and resume usability from the command line immediately.

Actual behavior

  • Prompted for upgrade and given the okay
  • Upgrade processes and completes
  • Docker restarts (as observed by the top bar icon)
  • Executing docker ps on the command line hangs

Clicking the Docker icon and quitting, following by starting the Docker app again yielded a successful docker ps from the CLI.

Information

After the restart the resolved the issue:
OS X: version 10.11.4 (build: 15E65)
Docker.app: version v1.11.0-beta8.2
Running diagnostic tests:
[OK] docker-cli
[OK] Moby booted
[OK] driver.amd64-linux
[OK] vmnetd
[OK] osxfs
[OK] db
[OK] slirp
[OK] menubar
[OK] environment
[OK] Docker
[OK] VT-x


(Jamshid) #2

Yup, me too. Glad quitting Docker and re-opening the application fixed it.
Your unique id is: D5A4F18E-8A2A-42D2-970F-6C3851ECFEBB


(Justin Wilson) #3

Ditto:

MBP 15" Mid 2014 2.5i7
OS X: 10.11.4
Docker.app: 1.11.0-beta8 (build:6072)


(Julien Maitrehenry) #4

Same for me, after a restart of docker it works.


(Tobias Gesellchen) #5

The docker ps did also hang for me after the upgrade. It wasn’t enough to restart the app or toggle the VPN mode, though. I tried re-installing with a fresh download from beta.docker.com, which also didn’t help. Only a complete system reboot made it work for me.

OS X: 10.11.4 (15E65)
Docker: Version 1.11.0-beta8 (build: 6072) 3c1bfeb0e86a9403f82302edfea4c4987cc2cb32


Docker ps not responding after Version 1.11.0-beta8 (build: 6072) update
(Dave Scott) #6

We’re aware of a bug in the “vmnet.framework” which sometimes appears after an upgrade. The symptom is that “docker ps” will show the VM’s IP address as “None” and accessing a containers ports will not work. If this happens, you can switch to exposing ports on localhost rather than docker.local with

pinata set native/port-forwarding true

HTH,
Dave


(Camilonova) #7

This worked for me. Thanks. Do you think it will be fixed in the next release? I would like to use docker.local instead of localhost