Docker Community Forums

Share and learn in the Docker community.

Docker ps not responding after Version 1.11.0-beta8 (build: 6072) update


(Sam Dengler) #1

Expected behavior

“docker start {container}; docker ps | grep {container}” should start and show the container running.

Actual behavior

“docker start {container} response” but “docker ps” hangs.

Information

The same container was running okay with the previous version of the beta.

➜ ~ pinata diagnose -u
OS X: version 10.11.4 (build: 15E65)
Docker.app: version v1.11.0-beta8.2
Running diagnostic tests:
Error docker ps: timeout after 10.00s
Thread 6 killed on uncaught exception Misc.Failure
Error docker ps: timeout after 10.00s
[ERROR] docker-cli docker ps failed: Misc.Failure
[OK] docker-cli
[OK] Moby booted
[OK] driver.amd64-linux
[OK] vmnetd
[OK] osxfs
[OK] db
[OK] slirp
[OK] menubar
[OK] environment
[OK] Docker
[OK] VT-x

Steps to reproduce the behavior

  1. start docker application
  2. from the command line: docker start {container}
  3. from the command line: docker ps

(Jason Meridth) #2

I’m seeing the exact same error. Any resolutions? Thanks for any feedback.

I followed the instructions to run nginx container locally and then tried to run docker ps and it just hangs. I provided feedback, got unique ID for all correspondence.

Also http://docker.local is inaccessible.


(Sam Dengler) #3

The “pinata set” command from this post fixed it for me.


(Jason Meridth) #4

all works for me now after upgrading to Beta9 that came out today. Hope the same for you.

Cheers,
Jason