Docker Community Forums

Share and learn in the Docker community.

Docker for Mac cannot start


(Yuankaiz) #1

New to the forum… report something that prevents Docker from start.

Diagnose ID: FA55BB06-4A30-4601-9F2C-CD0C683E0FFC

Expected behavior

starting…

Actual behavior

not starting…

Information

  • host distribution and version (OSX 10.11.5)

when I want to set preference, it displays
"Error
Failed to retrieve settings values.
frontend process failed"


(Andyburke) #2

Seeing the same thing after removing .qcow2 file to handle out-of-disk-space issue in containers:

8359E0EF-8B9B-400C-98AA-9073117F7A04


(Christian Hillerkus) #3

Had the same problem. Here’s how I fixed it:

  1. Stop Docker for Mac
  2. Delete “~/Library/Containers/com.docker.docker/”
  3. Start Docker for Mac

(Chuckg) #5

Had the same issue. @ckesselh’s resolution worked for me as well.

  • Just updated to Version 1.12.0-rc2-beta17 (build: 9779), was on 1.11.x previously.
  • OS X 10.11.5

(Yuankaiz) #6

@ckesselh’s solution does not work for me though.
Logs from console have many errors:

EOF reading packet from Unix domain socket: closing

Failed to read hello from client

File /var/run/docker.sock is a symlink or a socket

Symlinks are not correctly installed.

dial unix /Users/yuankai 1/Library/Containers/com.docker.docker/Data/s20: connect: no such file or directory

frontend process failed

Fatal unexpected failure: Couldn’t connect to database at /Users/yuankai 1/Library/Containers/com.docker.docker/Data/s40: No such file or directory

Failed to connect to db: &net.OpError{Op:“dial”, Net:“unix”, Source:net.Addr(nil), Addr:(*net.UnixAddr)(0xc82030e300), Err:(*os.SyscallError)(0xc82030e340)}

Try 9/100 failed to connect to db: dial unix /Users/yuankai 1/Library/Containers/com.docker.docker/Data/s40: connect: no such file or directory

What is happening in behind?
I’ve reinstalled the application many times, it still does not work.

Any help is appreciated.