Docker Community Forums

Share and learn in the Docker community.

Docker-for-window & powershell display problem


(Sorcererstone) #1

I tried to run an ubuntu image with powershell (both in regular mode and in administrator mode and both have the same problem). There is only 1 docker image in my system & it is ubuntu. The command I used was: “docker run -it ubuntu /bin/bash” & hit return.

In powershell, the cursor return a blank line.

I changed the resolution of the powershell screen & I had tried to change the resolution of windows OS to be bigger & smaller (as suggested by other forums). Same result.

When I brought up another powershell to stop this ubuntu container, the blank line in the previous powershell windows returned with:

“]0;root@6130d15c8d5f: /root@6130d15c8d5f:/# exit”

I brought up a DOS command box and ran the same exact command. I got the correct output:
“root@2e3508c74790:/#”

How do I get powershell display properly?

I have all the latest updates on this Win10pro. So, it is not an updates issues. I had unchecked the powershell windows option. Rebooted. Rechecked the powershell option. I had uninstalled and reinstalled Docker-for-Windows.

Thanks in advance.