Docker Community Forums

Share and learn in the Docker community.

Docker for Windows initial tutorial: no matching manifest for windows/amd64 10.0.15063 in the manifest list entries

Hi,

I just installed Docker for Windows (v2.1.0.1, Stable) on win10 build 1703 OS 15063.1631 and am going thru the Hub’s 6-step tutorial. https://hub.docker.com/?overlay=onboarding

On step 3: Build there’s this step:
cd doodle\cheers2019 ; docker build -t MyUserName/cheers2019 .
When I run the above, docker responds with:

Sending build context to Docker daemon 12.8kB
Step 1/9 : FROM golang:1.11-alpine AS builder
1.11-alpine: Pulling from library/golang
no matching manifest for windows/amd64 10.0.15063 in the manifest list entries

Docker info
Client:
Debug Mode: false

Server:
Containers: 0
Running: 0
Paused: 0
Stopped: 0
Images: 0
Server Version: 19.03.1
Storage Driver: windowsfilter
Windows:
Logging Driver: json-file
Plugins:
Volume: local
Network: ics l2bridge l2tunnel nat null overlay transparent
Log: awslogs etwlogs fluentd gcplogs gelf json-file local logentries splunk syslog
Swarm: inactive
Default Isolation: hyperv
Kernel Version: 10.0 15063 (15063.0.amd64fre.rs2_release.170317-1834)
Operating System: Windows 10 Enterprise Version 1703 (OS Build 15063.1631)
OSType: windows
Architecture: x86_64
CPUs: 4
Total Memory: 31.91GiB
Docker Root Dir: C:\ProgramData\Docker
Debug Mode: true
File Descriptors: -1
Goroutines: 30
System Time: 2019-08-12T15:47:49.0726137-04:00
EventsListeners: 2
Registry: https://index.docker.io/v1/
Labels:
Experimental: false
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false
Product License: Community Engine

Any assistance would be appreciated. Might something have gone wrong with the install?

Thanks in advance

Hi, I had the same issue. And I solved by switching it to linux container.

  1. In the docker desktop, select, “Switch to linux container” (maybe need to restart);
  2. run the command again in the powershell.
1 Like

I had same issue. But I really want to use a Windows container, not linux. Any suggestions.