Docker Community Forums

Share and learn in the Docker community.

Docker for Windows with WSL Ubuntu 18.04


(Robear0001) #1

I started using Docker because I was shown how it could save me some time in cross-platform development. I was able to set up ubuntu docker containers that I can connect to from visual studio. I did this through the wsl (windows subsystem for linux) through the exposed daemon on port 2375.

I was working on a separate project so I didn’t use docker for several weeks. After, I start up docker for windows, opened wsl and every docker command is telling me it cannot connect to the daemon. So I uncheck the daemon expose option, restart docker, reset the option, restart, still can’t be seen.

After removing wsl and resetting it up from scratch following the same instructions I used before it still doesn’t work. Of note, I cannot use powershell either, all docker commands just sit there forever doing nothing.

So, I go into Docker settings, reset, and reset to factory settings. That’s right, lose all my images, lose all my containers, but hey, now, wsl can connect to the daemon. So, I find an old image file for docker, load it in. Make a container out of the image. Update everything to get me back to where I was. Can still access everything in wsl and I work for a while. Dog has to go outside, so shut down and go. Comeback later, boot up, turn everything back on. That’s right, no matter what I do, cannot access the daemon again. Turning off firewalls anything I could think of. No connection. Only way to get it back, reset to factory settings and lose everything I have, AGAIN.

I lost quite a bit of time learning to use docker, and now much more trying to get it working. I do not have time to reload all my images and containers every time I need to work.

Anyone have any idea what is going on.

R


(Robear0001) #2

I think the fact that it worked after resetting was a fluke. I cannot get it to connect for anything right now. As that I cannot load my images as I cannot connect to the daemon. I am dead in the water. I blew another 12 hours on this today and this is ridiculous. I removed all firewalls virus protection adware protection everything exposing my machine to the outside world, and I cannot get the daemon to be seen from inside wsl. Unless someone from docker can tell me what the heck is going on and why this started happening in the last several weeks when everything was working for months. I am done with it. I do not have the time to waste on this when I have a job that needs finishing.

R