Docker Community Forums

Share and learn in the Docker community.

How to Check Daemon Port


(Ryanmcintyre) #1

I use WSL to talk to Docker for Windows through the daemon being exposed using the checkbox setting exposed on the General tab of the Settings window. Lately, WSL isn’t able to connect 100% of the time so I’m trying to troubleshoot the issue. I’ve been able to get it working by un-checking the setting, restarting Docker, checking the setting, and restarting Docker, but that’s only worked a couple times and usually does not.

I’m wondering if there is a firewall or networking issue, but I don’t know what to check. How can I verify that the daemon is being exposed by the MobyLinuxVM properly and what should I look for in my Windows Firewall settings, if anything? Any other tips appreciated.

Docker 18.06.1-ce-win73 (19507)
Windows 10 1809


(Ryanmcintyre) #2

I switched to Edge from Stable and it’s working again. Would still like to hear more about how to check daemon status in D4W as I’m guessing this will stop working at some point based on recent experience.


(Ryanmcintyre) #3

Nope, that wasn’t it. Ran into the issue again. Tried resetting to Stable and it still didn’t work. Set Docker to not start on login and rebooted, then started Docker, and it’s working now. I’ll post back if I find something repeatable.


(Christian Sciberras) #4

One possibility (which I’m using) is to use Docker Toolbox (or Docker for Windows) via WSL simply by using docker.exe <command> from the linux terminal and/or alias docker.exe with docker so that it can be used by linux programs/scripts impervious to Windows/WSL.
With this, I’d avoid needing a linux variant of docker running inside WSL and whatever downfalls that might have.