Docker Community Forums

Share and learn in the Docker community.

Docker hangs in few minutes after startup (issue started after updating to latest build last night)


(Hardikdocker) #1

Expected behavior

docker containers keep running as normal

Actual behavior

after few minutes of containers are started, all containers stops responding, “docker ps” not responding either

Information

diagnostic id D07B9E19-61FA-4FDA-8E88-983E248D880C

Docker for Mac: version: mac-v1.12.0-beta18-3-gec40b14
OS X: version 10.11.5 (build: 15F34)
logs: /tmp/20160708-084841.tar.gz
failure: docker ps failed: Failure(“docker ps: timeout after 10.00s”)
[ERROR] docker-cli
docker ps failed
[OK] app
[OK] menubar
[OK] virtualization
[OK] system
[OK] osxfs
[OK] db
[OK] slirp
[OK] moby-console
[OK] logs
[OK] vmnetd
[OK] env
[OK] moby
[OK] driver.amd64-linux

Steps to reproduce the behavior

  1. Reboot MAC (!!)
  2. Start Docker
  3. Start containers
  4. Wait for 3-4 minutes
  5. docker ps (not responding), all containers stop responding

(Jeregrine) #2

I am experiencing this exact same issue

Information

Docker for Mac: version: mac-v1.12.0-beta18-3-gec40b14
OS X: version 10.12 (build: 16A239j)
logs: /tmp/20160708-154838.tar.gz
failure: docker ps failed: Failure(“docker ps: timeout after 10.00s”)
[ERROR] docker-cli
docker ps failed
[OK] app
[OK] menubar
[OK] virtualization
[OK] system
[OK] osxfs
[OK] db
[OK] slirp
[OK] moby-console
[OK] logs
[OK] vmnetd
[OK] env
[OK] moby
[OK] driver.amd64-linux

ID 80BB0E3E-C375-4EE3-8B7A-9FA2175AAF5A


(Jeregrine) #3

To be clear I’ve tried:

Reseting, re-installing, rebooting.


(Jeregrine) #4

This is still an error in latest version

9F5AB44E-A406-4E84-AA1F-54CF96E9DA15

Docker for Mac: version: win-v1.12.0-beta19
OS X: version 10.12 (build: 16A239j)
logs: /tmp/20160714-122002.tar.gz
failure: com.docker.osxfs is not running
[ERROR] docker-cli
docker ps failed
[OK] app
[OK] moby-syslog
[OK] virtualization
[OK] menubar
[OK] system
[ERROR] osxfs
com.docker.osxfs is not running
[OK] db
[OK] slirp
[OK] moby-console
[OK] logs
[OK] vmnetd
[OK] env
[OK] moby
[OK] driver.amd64-linux


(Rahuljawale) #5

I am experiencing the same on Ubuntu Server 16.04 (with all the latest patches).

Does anyone know what logs I would need ?


(Mike) #6

I’m experiencing the same problem, docker won’t even start on my mac

D832E654-EE36-4698-B6BA-8F0B924B5EAC
Docker for Mac: version: mac-v1.12.0-beta20
OS X: version 10.11.6 (build: 15G31)
logs: /tmp/20160725-080217.tar.gz
failure: docker ps failed: Failure(“docker ps: timeout after 10.00s”)
[ERROR] docker-cli
docker ps failed
[OK] app
[OK] moby-syslog
[OK] virtualization
[OK] menubar
[OK] system
[OK] osxfs
[OK] db
[OK] slirp
[OK] moby-console
[OK] logs
[OK] vmnetd
[OK] env
[OK] moby
[OK] driver.amd64-linux


(Daniel Alan MIller) #7

Still experiencing this issue where Docker never finishes starting up and will always show “Docker starting…”, not sure how to look up logs.

Version 1.12.0-rc4-beta20 (build: 10404)
32ce3bdb164320603f1c2d1fb2ba32a43477ef3d


(Mike) #8

Performed a reset to factory defaults and now I’m able to run docker again. Will keep a close eye on the whale icon in my taskbar the coming days though