Docker Community Forums

Share and learn in the Docker community.

Docker ps failed


(Jay Liang) #1

Expected behavior

docker ps should return running containers

Actual behavior

command hangs forever

Information

Docker for Mac: version: mac-v1.12.0-beta16.2
OS X: version 10.11.5 (build: 15F34)
logs: /tmp/20160626-185352.tar.gz
failure: docker ps failed: Failure(“docker ps: timeout after 10.00s”)
[ERROR] docker-cli
docker ps failed
[OK] app
[OK] menubar
[OK] virtualization
[OK] system
[OK] osxfs
[OK] db
[OK] slirp
[OK] moby-console
[OK] logs
[OK] vmnetd
[OK] env
[OK] moby
[OK] driver.amd64-linux

Steps to reproduce the behavior

  1. call docker ps

Docker server in VM not responding - docker, docker-compose client comands hang
(Jay Liang) #2

solved by quit docker and start it again,
restart won’t work


(P3000) #3

I’ve tried everything from quitting/restarting Docker to restarting the physical OS X machine, and still get this error. I can’t be the only one with this frustrating issue! Diagnostic #CF8D89D6-13F6-4C9D-9E13-F92A987450FB


(David Witherspoon) #4

I ran into the same issue and I was not able to fix it by restarting either. I did remember that I had changed my preferences (memory and CPU settings) before the last update. So I decided to reset the setting back to original and after the app restarted it all worked again. Then I was able to go back into preferences and put my CPU and memory settings back.

I hope that works for you.


(Pcssi) #5

I ran into this issue.

Diagnostic ID:
938E9151-C826-4614-BC84-6126AC821B40

How I resolved it was by deleting the $HOME/Library/Containers/com.docker.docker/Data/ directory which is not an ideal workaround as it blew away all my local images.

I looked through the docker-system.log in /tmp/<date timestamped file name convention>.tar.gz .


Docker[com.docker.slirp][2830] : attempting to reconnect to database on unix $HOME/Library/Containers/com.docker.docker/Data/s40

In retrospect, I would have started by taking a more limited approach to removing directories; maybe starting with $HOME/Library/Containers/com.docker.docker/Data/s40.

Hope this helps those with this issue.

[edit] resolved the issue.


(P3000) #6

@dwitherspoon / @pcssi,

Thanks for the suggestions! Changing the CPU/RAM settings didn’t work. Eventually, I had to use the “Factory Reset” feature, which seems to effectively start from scratch. This was highly undesirable since I lost all my local images and containers, but at least i’m rolling again. :confused:

For anyone in the same boat after an upgrade, if it’s not too burdensome to restore or recreate your images, I wouldn’t waste a lot of time trying to manually troubleshoot. The factory reset is crude, but effective.


(Pcssi) #7

@p3000, great suggestion. This is essentially what I did from the command line. I was not aware the application exposed this.

For those who are unaware, if you click on the Docker icon in the menu bar and navigate to Preferences… ( keyboard shortcut ⌘, ); the following window will show up.

The General, Advanced, or Uninstall / Reset “tab” will be selected depending on the state of your application.


(John Zila) #8

Also broken here, diagnostic ID F92CC360-9C07-4D1A-9A70-FEF8218EEECE. Restarting docker does nothing, and rebooting the PC does nothing. The Docker tray widget hangs on Docker starting...