Docker Community Forums

Share and learn in the Docker community.

Docker Hub Builds: no space left on device

Lately my automated builds on Docker Hub have been failing with the following error:

Error pushing to registry: mkdir 
/var/lib/docker/graph/_tmp/da0402489acc4b8ed78dbd7ea7651386c6d0e6dc5b8dc209ee1349c573741737:
 no space left on device

Whats going on?

2 Likes

It seems rather random when it fails or not. Just recently a couple new builds worked correctly, but now its failing with the same no space error. Maybe random build nodes run out of space?

We’re getting this same error:

mktemp failed: mkdir /var/lib/docker/graph/_tmp/4ea76950ca367a6cc164f585c26c24ee222660266d10cdc46ac7eacef1f102e7: no space left on device

Trying to build again, not automated.

Re-triggering a manual build worked. Huh.

even with manual build we get this error:

ApplyLayer exit status 1 stdout: stderr: open /tmp/npm-1-nfLWUHJn/registry.npmjs.org/fibers/-/fibers-1.0.5.tgz-unpack/binding.gyp: no space left on device

1 Like

This is happening a lot more now since the recent Docker upgrades. Basically one out of 10 builds succeeds.

I’m having the same issue in docker hub. From time to time it works - probability < 10%.
Project - https://hub.docker.com/r/fullstackml/oneboxml-r/

Could you please recommend any solution?

Error:
mkdir /var/lib/docker/overlay/2867df03637e7cc7e9daf9a51ebfcee93cc1fa46f397d47f4fc76c572b793634/tmproot771847485/usr/local/lib/R/site-library/NISTnls/original: no space left on device

I’m getting the same error right now, and there IS space on the device …

I’m getting the same issue. Was this resolved?

Hub URL: https://hub.docker.com/r/uexpl0it/csgo-server

I cannot delete my private or public repository from docker hub

When i trying to delete public or private repository from docker hub i got error

Command which i was trying to delete from terminal
curl -s -v -H “Authorization: JWT ${HUB_TOKEN}” -X DELETE “https://hub.docker.com/v2/repositories/mohd/test2/”

After execute i got error
image
Mark bundle as not supporting multiuse
< HTTP/1.1 401 UNAUTHORIZED

  • Connection #0 to host hub.docker.com left intact
    {“detail”: “Authentication credentials were not provided.”}