Docker Community Forums

Share and learn in the Docker community.

Docker Hub Webhook URL's not being accepted


#1

Webhooks with URLS like https://$something:1qFX1Ta1AyLxBgu0kqzm0GFunp33rHRzxp84kTjesdvG9shrWsaSudvRNTxd@something.scm.azurewebsites.net/docker/hook

are not being accepted and as marked as Invalid when submitted as webhooks. Similar URL’s were allowed before Docker Hub got the new Updated. With the New Update, the URL’s are not being accepted. Did I do anything wrong? I don’t think the URL is invalid as it is given by Azure App Service for continuous Integration.

Thank You.
Tarun Pothulapati.


(Ilia luk) #2

I have the same problem as well


#3

I have the same issue too.


#4

I have exactly the same issue and it prevents CI with Azure App Services.


#5

My firm is also having the same issue. Using the previous webhooks UI, we could add Azure-based URLs for our continuous delivery. With an update to our repositories however, we’ve lost that functionality as we can no longer add Azure-based URLs to Docker in the new UI. Any idea when this will be rectified? This is currently a major thorn in our CI/CD strategy.


#6

Maybe, we can have a URL redirection for now, using services like tinyurl, etc. I didn’t try it yet, but I guess it should work.


#7

TinyURL does not work, can you please put the dollar sign in your URL patterns, I have an old webhook with that dollar sign and it is working like a charm


(Rodrigo Reis) #8

Same problem here, url provided by Azure App Services CD doesn’t work


#9

I was successful in adding my Azure webhooks just a few moments ago. It appears as if the issue has been resolved? It’s probably worth everybody else checking their side as well.


(Ming He) #10

It should be fixed now.


(Rodrigo Reis) #11

I tried again and it worked. Thanks.