Docker image on IMX board not responding


I am quite new to docker. I am trying to port the docker to IMX (arm cortex-9) board.
I am included kernel support to have docker in  build. I flashed the file to IMX hardware.
I can see binary images of docker, dockerd, docker-shim on the /usr/bin.
However if I tried to with docker commands, no response. No docker commands accepted.
Even version or h is not working. Any idea why it is so?


did you start the dockerd?
To go into detail you also can check where is the error. Does it work if you use the IMX-docker with a dockerd somewhere else. And does it work if you use the IMX-dockerd with a docker from somewhere else.

Some commands it is working are

docker-containerd --version
containerd version 0.2.0 commit: 0ac3cd1be170d180b2baed755e8f0da547ceb267

ls -l //usr/bin/docker
-rwxr-xr-x 1 1000 1000 11724964 Jul 7 2017 //usr/bin/docker

I tried to start with dockerd, It didnot worked with dockerd command

/usr/bin# dockerd
-sh: /usr/bin/dockerd: No such file or directory

Did this gives any help to decide some hint what is missing?