Docker Community Forums

Share and learn in the Docker community.

Docker is unable to find image locally

I’m new to Docker. I installed it a few days ago and tried to follow through with the Docker Orientation and Setup as well as the quick start guide that opens automatically when you install the Docker Desktop App.

The orientation and setup suggests that that this is the output one should get when they run the code:

$ docker run hello-world

    Unable to find image 'hello-world:latest' locally
    latest: Pulling from library/hello-world
    ca4f61b1923c: Pull complete
    Digest: sha256:ca0eeb6fb05351dfc8759c20733c91def84cb8007aa89a5bf606bc8b315b9fc7
    Status: Downloaded newer image for hello-world:latest

    Hello from Docker!
    This message shows that your installation appears to be working correctly.
    ...

However, this is what I’m getting:

$ docker run hello-world
Unable to find image 'hello-world:latest' locally
docker: Error response from daemon: Get https://registry-1.docker.io/v2/: dial tcp: look
up registry-1.docker.io: no such host.
See 'docker run --help'.

I tried switching from Linux containers to Windows containers but it doesn’t solve the problem. I can’t seem to find any help online. What could be the problem?

Assuming you’ve not changed the image registry in some way, it could be that the hub was down or it’s being blocked by your firewall, security settings, etc.

I wrote a Docker for Web Developers book and video course because I couldn’t find good novice tutorials which advised how to create local development environments. Use the discount code dock30 for 30% off.