Docker Community Forums

Share and learn in the Docker community.

Docker is very slow - 'vmmem' is consuming all CPU

I have a dev setup running under windows with linux-based images for 1) my app server and 2) a postgres server.

While running docker recently after updating my Windows to the October update (1809), I am seeing that the response times for even simple queries have become abysmally slow (10 seconds instead of somewhere around 50ms).

I suspect it’s this Vmmem process which is causing the issue - it’s consuming as much as 60% CPU while consuming nothing else, and I noticed that the CPU usage only flares up whenever I start seeing the response times rising, so there might be a correlation.

This has made running docker under Windows a very painful experience. I tried searching for related issues, but didn’t find any relevant ones. Is there any fix for this which I can do to solve it?

4 Likes

@kumarharsh - I’m having the same issue. Did you find at least a temprorary solution?

I had the same issue. I’ve been able to fix it by increasing CPU, Memory and Swap.

You can change these settings under:
Settings > Advanced

Screenshot:

1 Like

I don’t have this option.

The other screens don’t have the option you’re showing either.

I don’t use Kubernetes.

So… now what’s the solution?

I don’t know what these apps are doing.

My computer is running slow. I have an i7 Windows 10 Pro with 16GB of RAM at 70% usage, and CPU is between 1 and 15% with Docker Desktop and Vmmem. I just used the install defaults and followed the tutorials.

I’m currently running the example-voting-app tutorial. I just ran the build command and came back from shopping.

I can’t fathom why these are constantly using CPU.

1 Like

@dockitdave To see this option, you have to run Docker vm in Linux mode, in Windows mode it is unavailable

Have you tried looking at Resources > Advanced ? I see the settings in there. Changed it and it seems to help, now CPU is running normal. See that memory consumption is now high though (make sense, vmmem properly was busy swapping). Thanks for the tip @ [tmuecksch]