Docker login: Dial tcp: lookup read udp i/o timeout

Same issue here as @dmikov, but with a private registry. Any advice?


+1 having this issue as well, with Docker for Mac 1.12.0-rc2. I have reset to factory default as well, still no dice.

1 Like

+1 Same issue with private registry


works for me!


Same here with Docker for Mac Version 1.12.0-rc2-beta16 (build: 9493). Reset does not help.

1 Like

Having a similar issue also on Version 1.12.0-rc2-beta16 (build: 9493)

$ docker pull alpine
Using default tag: latest
Error response from daemon: Get Get dial tcp: lookup on no such host

1 Like

There are at least two threads (including this one):

I can login to AWS ECR and pull images, but not the docker registry.

I have similar issue with Docker for mac. My diagnostic ID: E439CFAC-9936-4585-B8EB-7AB6E9CEA652

Previously I had working docker-machine with virtualbox. But I uninstalled everything(deleting every image/container) and removed any bashrc and /etc/hosts/ changes.

I have a wifi connection, if that info helps.

Version Version 1.12.0-rc2-beta16 (build: 9493)

I believe I’ve tracked this down to truncated DNS responses from upstream DNS causing Docker’s embedded DNS server to fail since it seem to be listening via TCP:


Same issue (I use internal bind DNS). Is there a place to open a bug for this, if not already?

$ dig | head -n2
;; Truncated, retrying in TCP mode.

$ dig @ | head -n2
; <<>> DiG 9.8.3-P1 <<>> @

Diagnostic ID: 08466D37-2F75-4FBA-9D4D-6DF461FA8960

1 Like

FYI I just restarted the bind daemon and oddly it now returns a DNS response small enough not to be truncated into TCP mode, which fixed docker as well.

+1 on this issue.
I restarted which didn’t clear the issue - oddly I disabled my wireless and forced my wired network connection, restarted and the log in went through and I was able to push my image to Docker Hub.

Here’s the issue on Github – it’s been identified and possibly fixed but not released.

1 Like

what solved it for me is adding an A record for in my hosts file, e.g.:

then it started working.

1 Like

Thanks, it works well on my Docker on Windows Server 2016.

The problem solved by reset the docker settings to factory defaults. Thanks @skarger

1 Like

What is the IP - That of the Registry?

I tried all of the above and nothing worked, running win 10
but i found it!

for my work i need a socks client (opentext socks) to connect to our virtual environment
this application interfered with the network connections docker tried to establish, after disabling the socks client all went well !

regards JW

Thank you! for posting this. This resolved my issue too!

I have solved the same issue by resetting the router dns cache, I suggest to try it.

I have struggled so much on this, after all, this helped on Ubuntu.

echo "nameserver" | sudo tee /etc/resolv.conf > /dev/null

p.s. I tried manually adding nameserver to this file but it didn’t solve the problem, command above - did!