Docker Community Forums

Share and learn in the Docker community.

ERROR: Network timed out while trying to connect to index.docker.io

Expected behavior

Pull the right images from Docker images repo.

Actual behavior

Getting an error:

ERROR: Network timed out while trying to connect toindex.docker.io/v1/repositories/library/mariadb/images. You may want to check your internet connection or if you are behind a proxy.

Information

Visit the link directly from browser index.docker.io/v1/repositories/library/mariadb/images it loads fine with hash checksums of all images.

  • the output of:
    • Moby Menu > Diagnose & Feedback on OSX
  • a reproducible case if this is a bug, Dockerfiles FTW
  • page URL if this is a docs issue or the name of a man page
  • host distribution and version ( OSX 10.10.x, OSX 10.11.x, Windows, etc )

Diagnostics: 54E410A9-0120-4F92-982D-E8E66CD4946F

Docker for Mac: version: mac-v1.12.0-beta17
OS X: version 10.11.5 (build: 15F34)
logs: /tmp/20160701-151214.tar.gz
[OK] docker-cli
[OK] app
[OK] menubar
[OK] virtualization
[OK] system
[OK] osxfs
[OK] db
[OK] slirp
[OK] moby-console
[OK] logs
[OK] vmnetd
[OK] env
[OK] moby
[OK] driver.amd64-linux

Docker Compose YAML file: https://github.com/letsencrypt/boulder/blob/fd095b888113f1b63964bfa1377b738cbb200a76/Dockerfile

Steps to reproduce the behavior

  1. git clone https://github.com/letsencrypt/boulder/
  2. cd boulder; docker-compose up

I’m getting the same issue as well. Those who aren’t using mac beta aren’t having the same issue. I’m on beta 18

I would output my diagnose information but that is also broken :wink: V1.12.0-rc3-beta18 missing Diagnose, and "Check for Update" and Auto-Update option cannot be changed

Yeah, docker pull is consistently failing for me.

Got another incident today (see below.) docker pull on a VritualBox VM on Mac works fine without hitch.

Sending build context to Docker daemon  16.9 kB
Step 1 : FROM nginx:1.9
Pulling repository docker.io/library/nginx
Network timed out while trying to connect to https://index.docker.io/v1/repositories/library/nginx/images. You may want to check your internet connection or if you are behind a proxy.

Ok, I just got a new release push from Docker. After upgrade, the new version

Version 1.12.0-rc4-beta20 (build: 10404)

just worked! Yay

Just re-installed 1.12.0-rc4-beta20 (build: 10404) while troubleshooting something else & I am now seeing this problem. Don’t seem to be able to pull anything.

I got it working with pure default Docker configuration (no manual DNS set to 8.8.8.8, no IP V6 deactivation), by removing Unlocator-related settings from the router (its specific DNS server, and maybe more problematic, static routes that redirected 8.8.8.8 and 8.8.4.4 to the router itself as recommended to get Chromecast working)! I had to reboot the router afterwards and disable/re-enable local network adapters. Strange that Docker is the only application which encountered issues because of this set-up.

I may have some useful information on this issue.

On OSX my list of DNS servers is (in this order):

  • 2001:4860:4860::8888
  • 2001:4860:4860::8844
  • 8.8.8.8
  • 8.8.4.4

But, if I rearrange the list so that the v4 addresses are at the top, it suddenly works.

So it seems that the issues are that a) it’s not falling-back to the second/third/fourth addresses in /etc/resolv.conf, and b) it doesn’t have access to the IPv6 internet.

Can anybody else confirm that making sure the first DNS address is a v4 address fixes the issue?

Edit: Raised an issue for this: https://github.com/docker/for-mac/issues/9

I can confirm that doing this worked for me.

Yup this did it. Thank you @tomdxw!