Docker Community Forums

Share and learn in the Docker community.

Cannot connect to docker registry/auth servers


(Patryk Kuzmicz) #1

Expected behavior

Run a docker or pull image from registry

Actual behavior

Get error:

$ docker run -it ubuntu bash

Unable to find image 'ubuntu:latest' locally
docker: Error response from daemon: Get https://registry-1.docker.io/v2/library/ubuntu/manifests/latest: Get https://auth.docker.io/token?scope=repository%3Alibrary%2Fubuntu%3Apull&service=registry.docker.io: dial tcp: lookup auth.docker.io on 192.168.65.1:53: dial tcp 192.168.65.1:53: getsockopt: connection refused.
See 'docker run --help'.

The same error is for ‘docker pull ubuntu’.

Information

Diagnostic ID: F46B9EFD-DCC6-41FC-8165-C261EE3D04B6

Docker for Mac: version: mac-v1.12.0-beta16.2
OS X: version 10.11.5 (build: 15F34)
logs: /tmp/20160625-175629.tar.gz
failure: No error was detected
[OK] docker-cli
[OK] app
[OK] menubar
[OK] virtualization
[OK] system
[OK] osxfs
[OK] db
[OK] slirp
[OK] moby-console
[OK] logs
[OK] vmnetd
[OK] env
[OK] moby
[OK] driver.amd64-linux

Steps to reproduce the behavior

  1. Run a Docker.app
  2. Run any docker (ex. docker run -it ubuntu bash) or
  3. Pull any image from public registry

Docker login: Dial tcp: lookup index.docker.io read udp i/o timeout
(Ggilley) #2

I’m seeing the same problem this morning.


(Micahzoltu) #3

Any fix for this? Both me (Docker for Mac) and my co-worker (Docker for Windows) are dead in the water right now.


(Micahzoltu) #4

Note: Docker was working fine for both of us on Friday. Was there an update on Friday or over the weekend that could have caused this? If so, is it possible to rollback? Are there any workarounds so we can get back to working?


(Micahzoltu) #5

Switching to my company’s guest WiFi allowed me to workaround the issue, of course this won’t work long-term as I need to be on the corporate VPN to actually do my job. :smiley: Are others with this problem on a corporate VPN?


(Vkat) #6

Same issue this morning. I am on a corporate network but not using any VPN connectivity.


(Twhid) #7

Seeing same. Not on a VPN. Also was working fine on Friday and stopped working today.

edit:
Am on my corporate LAN.

$ docker login -u twhid
Password:
Error response from daemon: Get https://registry-1.docker.io/v2/: \
Get https://auth.docker.io/token?account=twhid&client_id=docker&offline_token=true&service=registry.docker.io: \
dial tcp: lookup auth.docker.io on 192.168.65.1:53: no such host

(line breaks mine)


(Zzkpl) #8

Same here - osx 10.11.5 with docker version 1.12.0-rc2-beta16 (build: 9493) - diagnostic id A605F58B-5395-4031-B778-661DFA23AC21


(Twhid) #9

Following up on this.

Somehow, this morning everything worked again.

Possible there were DNS issues that only some folks encountered. It would be nice if the moderators could comment on what, if any, changes they made to fix the issue. Or if they were aware of other network issues that could have caused the problem.

edit:
This thread has more:


(Symbyte) #10

This issue seems to have returned today:

$ docker pull hello
Using default tag: latest
Error response from daemon: Get https://registry-1.docker.io/v2/library/hello/manifests/latest: Get https://auth.docker.io/token?account=symbyte&scope=repository%3Alibrary%2Fhello%3Apull&service=registry.docker.io: dial tcp: lookup auth.docker.io on 192.168.65.1:53: no such host

Docker for Mac: version: mac-v1.12.0-beta16.2
OS X: version 10.11 (build: 15A284)
Diagnostic ID: 6FB67760-38D3-43CE-9915-17A09EB63654


(Robertsilve) #11

Same issue for me

$ docker pull hello
Using default tag: latest
Error response from daemon: Get https://registry-1.docker.io/v2/library/hello/manifests/latest: Get https://auth.docker.io/token?scope=repository%3Alibrary%2Fhello%3Apull&service=registry.docker.io: dial tcp: lookup auth.docker.io on 192.168.65.1:53: dial tcp 192.168.65.1:53: getsockopt: connection refused

Docker for Mac: version: mac-v1.12.0-beta17
OS X: version 10.11.5 (build: 15F34)


(Patryk Kuzmicz) #12

Workaround for me is to disable WIFI, restart Docker, and enable WIFI… When I restart Docker service with enabled WIFI it doesn’t help.


(V1k0d3n) #13

Same issue here this morning for me. @jamzed workaround works for me.


(Highwayoflife) #14

Several of our users here on Mac machines are experiencing the same issue on Docker Version 17.09.0-ce-mac35 (19611). The solution was to disconnect from VPN, and refresh the terminal (also may need to restart Docker), before running the docker pull commands.