Docker Community Forums

Share and learn in the Docker community.

Docker login fails with error message: "Error saving credentials: error storing credentials - err: exit status 1, out: `User interaction is not allowed.`"

I am unable to perform any docker login actions on MacOS Big Sur (11.6, build 20G165). When I try, I get the following message:

Error saving credentials: error storing credentials - err: exit status 1, out: `User interaction is not allowed.`

This occurs when using either my Docker Hub login or when trying to use my Amazon ECR credentials. Both logins work perfectly from my Fedora Server 34 machine, running docker client version 20.10.10.

Here is my Docker version info:

Client:
 Cloud integration: 1.0.17
 Version:           20.10.8
 API version:       1.41
 Go version:        go1.16.6
 Git commit:        3967b7d
 Built:             Fri Jul 30 19:55:20 2021
 OS/Arch:           darwin/amd64
 Context:           default
 Experimental:      true

Any help resolving this issue would be greatly appreciated. Thanks for taking the time to read.

Do you run docker login on MacOS in an SSH session from an other device?

I do, but I also receive this error when running the command directly on macOS, not using ssh.

I could not reproduce the issue but you can try this:
https://www.simplicidade.org/notes/2017/03/24/user-interaction-is-not-allowed/

I hope it helps.

I figured it out - docker login works on macOS in a local shell but not inside a tmux session. It also does not work from an ssh session. It does work inside a tmux session on my Linux box. Not quite sure what’s going on here, but glad I was able to isolate where the failure seems to happen.

I can understand SSH but I tried in tmux and it worked.

I upgraded to MacOS Monterey and this problem disappeared, it even works over SSH. I am utterly baffled but hope that if someone in the future finds this issue they try upgrading. Thanks Akos for your help, I appreciate you <3

Thank you for your feedback! I am glad it helped.