Docker Community Forums

Share and learn in the Docker community.

Docker-machine - IP address conflict


(Priyanka91acc) #1

Here are my environment:

Windows 7 64 bit
Docker for windows
When I create new machine, I encounter the IP address conflict:

IP Address conflict

And the console is stuck at phase starting VM

Creating VirtualBox VM…
Creating SSH key…
Starting VirtualBox VM…
Starting VM…
Furthermore, when I press Ctrl-C to stop the script and run eval “$(docker-machine env dev)”, I receive following error:

Also more than 60 tries attempted error in creating VM encountered
$ eval "$(docker-machine env dev)"
open C:\Users\jacob.phan.docker\machine\machines\dev\ca.pem: The system cannot
find the file specified.


(Rick van Hal) #2

I’m experiencing the same issue.
Also running win7 64bit

I tried to change the networksettings of the newly created VM. There I choose another VirtualBox Host-only adapter. Now I’m able to use docker-machine start|stop for that machine, but still unable to use eval “$(docker-machine env dev)”. Propably the certs aren’t created due to the fact that ‘docker-machine create’ did not finishing right.


(Ralph Kincade) #3

does the cert exist at the file location C:\Users\jacob.phan.docker\machine\machines\dev\ca.pem ?

I think you are correct in that the docker machine create command does not finish , what happends if you attempt to run the docker machine command on say digital ocean ?


(Evan) #4

Thank you for the feedback. Would you mind posting an issue in Machine Github issue tracker so we can further debug? You can file an issue here: https://github.com/docker/machine/issues


(Keithinaustin) #5

Aside from posting this on Github, is there more that can be done to recover from this? I’m having the same problem. Install of 1.8.1 on Windows 7 64-bit. I had previously installed virtual box a couple of months back. I had an IP address conflict during install. Got repeated ssh errors, Ctrl-C’d out of that, now things don’t work. Tried an uninstall (got the ominous “some components will have to be manually uninstalled”) and re-install, same problem.

When I run: docker run hello-world
I get:
Post http://127.0.0.1:2375/v1.20/containers/create: dial tcp 127.0.0.1:2375: ConnectEx tcp: No connection could be made because the target machine actively refused it…

  • Are you trying to connect to a TLS-enabled daemon without TLS?
  • Is your docker daemon up and running?

Moved a little further down the installation guide, though. When I run: docker-machine env --shell cmd default
(default is the name of the docker-machine VM) I get:
open C:\Users\kallen.docker\machine\machines\default\ca.pem: The system cannot find the file specified.

The directory exists but there is no ca.pem file there. There is a ca.pem file at C:\users\kallen.docker\machine\certs

Can anyone suggest a next step?


(M3so) #6

Was having similar issues.
This solution may help for now …

https://github.com/docker/machine/issues/1573#issuecomment-138866765