Docker Community Forums

Share and learn in the Docker community.

Docker-machine upgrade my-machine shows no effect


(Mxab) #1

Hi,
I upgraded my docker toolbox to 1.10 and was trying to use docker compose v2 to run docker containers on an old docker-machine digital ocean machine (created with 1.9)

Since I got then the error

ERROR: client is newer than server (client API version: 1.22, server API version: 1.21)

I thought I need to run docker-machine upgrade my-machine, the output then was:

Waiting for SSH to be available...
Detecting the provisioner...
Upgrading docker...
Restarting docker...

without any errors

but when I run docker-machine version my-machine it still prints 1.9 and I also still get the same docker errors about the client/server api difference

Is this a bug or did I get something wrong about docker-machine upgrade


(Ryan Watts) #2

I’m having the same issue did you ever find a solution?


(Mxab) #3

Nope, I opened an issue for that at the github machine project #3096

but it seems that is actually an issue with most of the drivers