Docker Community Forums

Share and learn in the Docker community.

Docker: Network timed out


(Crowne) #1

Expected behavior

expect to be able to pull images e.g. >docker pull hello-world

Actual behavior

docker: Network timed out while trying to connect to https://index.docker.io/v1/repositories/library/hello-world/images. You may want to check your internet connection or if you are behind a proxy…

Information

I have been unable to pull images, even just hello-world.
I have uninstalled and reinstalled,
I have done a factory reset
nothing seems to work.
I am not going through a proxy.
I am on Windows 10, connected directly to the internet through my WiFi router onto VDSL.

  • the output of:
    • Moby Notification > Diagose & Feedback on Windows
      693C7F84-3C44-42BB-AAEF-4FCE76281427/2016-07-09_15-40-15
  • a reproducible case if this is a bug, Dockerfiles FTW
  • page URL if this is a docs issue or the name of a man page
  • host distribution and version ( OSX 10.10.x, OSX 10.11.x, Windows, etc )
    C:\Users\Neil>docker version
    Client:
    Version: 1.12.0-rc3
    API version: 1.24
    Go version: go1.6.2
    Git commit: 91e29e8
    Built: Sat Jul 2 00:09:24 2016
    OS/Arch: windows/amd64
    Experimental: true

Server:
Version: 1.12.0-rc3
API version: 1.24
Go version: go1.6.2
Git commit: 876f3a7
Built: Tue Jul 5 02:20:13 2016
OS/Arch: linux/amd64
Experimental: true

Steps to reproduce the behavior

  1. docker pull hello-world

(Vinceskahan) #2

Me too. I have been unable to pull any images using the beta on a Intel NUC running Win10Pro, same message. Every attempt has a network timed out although the system is fine on the network (I’m VNC’d in, and it has fine internet connectivity).


(Vinceskahan) #3

Later update - I found a different thread that suggested hard-setting DNS in the Docker settings to 8.8.8.8 rather than the default ‘automatic’ setting. This changed was successful, the box can now download images. Thought I’d post here just so the O.P. knows the workaround…


(Crowne) #4

Thanks, that’s fixed it by setting the DNS to 8.8.8.8 instead of automatic in the settings panel.


(Ckhandhar) #5

Hi ,
I am trying to pull an image from docker hub and getting same error. I have also applied same settings for DNS but still it’;s not working for me. Can any one help me in to this ?


(Mayerwin) #6

Same issue here with the latest version. Changing DNS settings does not help. This is very frustrating.

Update: I got it working with pure default Docker configuration (no manual DNS set to 8.8.8.8, no IP V6 deactivation), by removing Unlocator-related settings from the router (its specific DNS server, and maybe more problematic, static routes that redirected 8.8.8.8 and 8.8.4.4 to the router itself as recommended to get Chromecast working)! I had to reboot the router afterwards and disable/re-enable local network adapters. Strange that Docker is the only application which encountered issues because of this set-up.


(Lmjohansen) #7

Had my own fun with this on docker 1.12.0 Stable on WinPro10.
Seems that the installation failed creating the NAT object for the “DockerNAT” Virtual switch.
My Solution:
Using PowerShell (as Admin)
Get-NetNat <- Shows all NAT objects

If Missing create one youself:
New-NetNat –Name “DockerNAT” –InternalIPInterfaceAddressPrefix “10.0.75.0/24”

I did not have to change DNS or remove IPV6 to get this to work.

Ref: http://docker-saigon.github.io/post/Docker-Beta/
Hope this will help someone else.