Docker Community Forums

Share and learn in the Docker community.

Network timeout..cannot pull images

dockerhub
docker

(Sameer4docker) #1

Hi ,
My current operating system is Windows 10 and
I have installed Virtual Box and then added an Ubuntu VM on top of that. I installed the docker-engine on Ubuntu and I added the insecure-registry.
But when I am trying to pull the images…it always says “Network timed out error”. I have tried most of the suggestions from Google, but to no success.
I cannot even pull images from public DockerHub like docker pull hello-world

Please do help me .

I am doing the commands in the following order

sudo docker pull hello-world

output:
using default tag : latest
Pulling repository docker.io/library/hello-world
Network timed out while trying to connect to https://index.docker.io/v1/repositories/lirary/hello-world/iamges. You may want to check your internet connection or if you are behind proxy.

My admin team confirms that we are not using any proxies in the company.

Few more details :slight_smile:
Operating System : Windows 10
Virtual Box : 5.1.2
VM : Ubuntu 16.04 LTS
Docker : 1.11.2

I am struggling with this not sure what is happening…Please help me.

Thanks and appreciate your feedback.


(Shashanksinha) #2

Delete the extra network adapter, this will fix the issue.


(Sameer4docker) #3

Thank you for the reply shashank, Where can I check if extra network adapter exists, please be little more detail.


(Sameer4docker) #4

I do not see any extra adapters here. Please help.


(Shashanksinha) #5

@sameer4docker Have you tried resetting docker to default values ? If not try that.

For my environment I am relying on Hyper-V instead of VirtualBox with docker version 1.12.0-rc3-beta18


(Sameer4docker) #6

Resetting docker to default value meaning?


(Shashanksinha) #7


(Sameer4docker) #8

I am doing this docker on Ubuntu VM