Docker Community Forums

Share and learn in the Docker community.

Docker not publishing ports

I ran

docker run -d --name=sonarr 
-e PUID=1000 
-e PGID=100 
-e TZ=Europe/London 
-p 10000:8989 
-v /srv/dev-disk-by-label-data/__docker_configs/:/config 
-v /srv/dev-disk-by-label-data/_downloads:/downloads 
-v /srv/dev-disk-by-label-other/_bin:/bin 
-v /srv/dev-disk-by-label-other/documentaries:/documentaries 
--restart unless-stopped 
ghcr.io/linuxserver/sonarr:develop

from the terminal and it didn’t publish the ports.

I’ve had the develop branch running for almost a year with no issues. I have been using Portainer to manage things for a while. I had to make a path change to map a folder for Sonarr to use for its trash folder.

I made the changes as I’ve done probably hundreds of times before on this and other containers but this time the ports didn’t publish.

I then removed the container and images and tried to create from the terminal, but the ports didn’t publish that way either.

At this point I’m not sure why they aren’t publishing.

I’ve also used the default image to with no luck. The configuration apart from the bin volume is the same as it’s been from the start.

I’ve also tried it without the bin volume in it, still doesn’t mount the ports.

I tried to create a different container with a different image and ports both through Portainer and the terminal and it created correctly and published the ports.

At this point I’m stumped.

The only thing I can think of is the previous process is still hanging onto the ports.

Docker does seem to have some curious issues when you stop an instance and start it again and all kinds of historical actions or processes can affect the running of a container. I’ve had endless problems with docker refusing to run containers that ran perfectly well before after being updated. The only way to get it working was to uninstall docker and reinstall it.