Docker on Raspberry pi and camera


I am completely new to DOCKER. Yesterday I have installed Docker on a raspberry pi 4 with portainer. I have deployed 2 Containers 1. Octoprint and 2. Home assistant. This works well so far. I can work with both. But in octoprint the raspberry pi camera is not reachable. There are many tutorials out there for USB webcams and Docker but non for the Raspberry Camera direct attached to the board. The camera worked as far as I only had the octoprint OS on the raspberry pi. In octoprint I have the failer massage that points on error ind vcdencmd I have to make sure that the camera is in the video group. This says nothing to me because I am not a Raspberry pi Pro. Is it a dockerproblem or a general Raspbian OS Problem?

It’s likely that you need to add a device to expose the Raspberry Pi camera to docker. Have a read of that link.

Thank you for that Link. I have already found it but for a complete newbie it is not working. You have to understand the mechanics of Docker to follow the steps.

Are you using docker, or docker compose?

If you are using docker, can you add this line to your docker run command:

   --device /dev/vchiq

Let me know what it does.

I tried this already but the console says docker run needs an argument. I am using portainer and found out that I can link an device to the container while deploying it. I haven’t tried it yet but this sounds promising.

Can you share your Portainer Stack here, please? Hide any personal details, mind you.

Thanks for trying to help me. I am now away from home for the next 5 weeks. Work!