Docker on Windows 2019 not working even after I fooled it its Win 10 Pro

Hi, I need to install Docker on Windows 2019 x64,
When I tried that it said "This version of OS is not supported, supported is Win 10 Pro etc, so according to some article, I have changed the regedit OS informations.
Now the installation proceeded and I can start DOCKER (almost).
BUT when I run the Docker now for first time (I get through the screens for Finishing settings : Recomended/Advanced settings) and for 2seconds I see the Docker window.
Then the window dissappears, and I am facing a Error : “Something went Wrong. Updating wsl : update failed: wsl.exe --update --web-download not supported” + got 3 Buttons to choose : Quit, Diagnose&Feedback, Reset Docker to factory defaults…which obviously doesnt help.
Any idea how to fix this and make it work?
Thanks for any reply

So if I understand it correctly, you want to install Docker Desktop on a not supported operating system and hoped that changing the registry will be enoiugh. Apparently not, but I’m not sure the error happens because of that. Ther eis another possibly related issue:

Maybe just your wsl version is outdated. You could install the latest x64 from here:

Nevertheless, what you do is not supported and remains not supported.


jojino, try to update your windows version to 22H2. Seems like older versions of windows “embed” a wsl.exe version that doesn’t support the “–web-download” option.
That solved that issue for me.