Docker only for Windows 10 and HyperV? surprised, disappointed

WIth great surprise and disappointment at the same time I read that the docker for Windows installer requires (mandatory) Windows 10 and HyperV. Virtual Box would then be no longer functioning. Are they mad or what?

Yes, we’re quite mad!

You can use Docker Toolbox if you prefer, that works on older Windows systems without Hyper-V: https://www.docker.com/products/docker-toolbox

3 Likes

Docker Toolbox will work great on Win7 boxes, and so will a thousand other custom Vagrant boxes lying around.

Life is good, my friend! :slight_smile:

Thanks. Good to know there is still Docker Toolbox as an escape.

Even if Toolbox eventually “dies”, please remember it is just a convenient package of otherwise standalone tools. If you have only VirtualBox and docker-machine you can still make it (docker-machine will download a proper VM). Even the native “docker client” for Windows may be installed separately, say, with DVM (https://github.com/getcarina/dvm).

Have fun!

2 Likes

… or client, machine, compose can be installed with chocolatey

Though I found Windows experience with docker pretty painful for me (lucky enough I don’t need to use it as my primary workstation any more)

Agreed. On Windows (or corporate HQ) I have long ago produced a properly
tooled Vagrant VM so that I pretty much forget that Windows exists.

Hi,

Sorry to bring this old thread up again. I have a question furthering this topic which I thought should be added here as opposed to creating an entirely new thread.

Does this mean that if we use toolbox that we can’t add a shared volume? From what I have read, shared volumes can only be added using the docker for windows i.e. going into settings and allowing for the sharing of drives. Is that true?

I had docker toolbox installed initially. I installed docker and added hyper-v, this obviously killed virtual box, though at that point neither toolbox nor docker worked because everytime I tried to get docker up and running I got the BSOD.

Is there a way to load a shared volume without docker? I have tried adding from both c and my d drives and both times the directory in the container is empty.

Thanks for any help.
Bobbie

No problem.

Can use docker cp with the docker ID. I did not know this.

Thanks,

You get shared volumes both ways, they should work with DfW or with Docker Toolbox, but the path you should mount in either case is different (as far as I remember). If using Toolbox you should be able to see the path in the VM that reflects the host “C:/Users” path on VirtualBox console (“shared folders”).

DfW was supposed to make your life easier. Try removing Toolbox (and VirtualBox) completely and reinstalling DfW afterwards.

If you want to go back to Toolbox you should disable the Hyper-V windows feature.

Keep trying!