Docker Community Forums

Share and learn in the Docker community.

Docker playground getting started page won't load on port 80

Docker Playground Issue

Short Sumary

I am new to docker and I want to try out the docker playground. I am having an issue with the Docker 101 Tutorial.

Steps done

  • Signed up for docker
  • Loged in to https://labs.play-with-docker.com/
  • opend a pwd and ran the command: docker run -dp 80:80 docker/getting-started:pwd
  • clicked on the port 80 badge

The Problem

After clicking the port 80 badge a new tab opend in my chrome browser with the url:
http://ip172-18-0-39-bsgjmclim9m000a3ifn0-80.direct.labs.play-with-docker.com/
The new page just keeps loading and after a while stops with this error screen:

Can someone tell me what the problem is?

I am currently facing this issue too.I pulled another docker image and ran it but after clicked port badge it did not work.I tried same container previously and then it worked fine.

The problem on my part is that something is blocking the port 80 on my pc. What we are trying to do in the tutorial is forward from the Port 80 from the docker container to the port 80 of the host (in my case my laptop). I set up my firewall so that port 80 was allowed, I also allowed port forwarding on my router, I ever deactivated my firewall and went online through my phone so that I didn’t use my router. I even tried changing the port on my pc. But nothing worked. Something is blocking all my ports if something is trying to reach my pc from the web.
Maybe you can try some of the hings I listed above. None worked for me but it may work for you. :slight_smile:

it might be worth replacing the port with
from
docker run -dp 80:80 docker/getting-started:pwd
to
docker run -dp 8080:80 docker/getting-started:pwd
and then open browser
http://0.0.0.0:8080

in my case i run that
docker run -d -p 8081:80 docker/getting-started

Clone this repo locally

git clone https://github.com/play-with-docker/play-with-docker
cd play-with-docker

Verify the Docker daemon is running

docker run hello-world

Load the IPVS kernel module. Because swarms are created in dind,

the daemon won’t load it automatically

sudo modprobe xt_ipvs

Ensure Docker daemon is running in swarm mode

docker swarm init

Get the latest franela/dind image

docker pull franela/dind

Optional (with go1.14): pre-fetch module requirements into vendor

so that no network requests are required within the containers.

The module cache is retained in the pwd and l2 containers so the

download is a one-off if you omit this step.

go mod vendor

Start PWD as a container

docker-compose up
Now navigate to http://localhost and click the green “Start” button to create a new session, followed by “ADD NEW INSTANCE” to launch a new terminal instance.