Docker pull throwing EOF exceptions

I recently installed Docker on my setup from Install on Mac | Docker Documentation. When I try to pull any image in my terminal, it throws following error:

(base) harshgoyal@lawn-128-61-61-143 ~ % docker pull docker/getting-started
Using default tag: latest
Error response from daemon: Get "": EOF
(base) harshgoyal@lawn-128-61-61-143 ~ %

(base) harshgoyal@lawn-128-61-61-143 ~ % docker version
Client: Docker Engine - Community
 Version:           20.10.23
 API version:       1.41
 Go version:        go1.19.5
 Git commit:        715524332f
 Built:             Wed Jan 18 20:42:16 2023
 OS/Arch:           darwin/arm64
 Context:           default
 Experimental:      true

Server: Docker Desktop 4.16.2 (95914)
  Version:          20.10.22
  API version:      1.41 (minimum version 1.12)
  Go version:       go1.18.9
  Git commit:       42c8b31
  Built:            Thu Dec 15 22:25:43 2022
  OS/Arch:          linux/arm64
  Experimental:     false
  Version:          1.6.14
  GitCommit:        9ba4b250366a5ddde94bb7c9d1def331423aa323
  Version:          1.1.4
  GitCommit:        v1.1.4-0-g5fd4c4d
  Version:          0.19.0
  GitCommit:        de40ad0
(base) harshgoyal@lawn-128-61-61-143 ~ %

System: Macbook Air M1 silicon chip with MacOS Ventura 13.1

Solutions tried:

  1. Restarting docker and Factory reset
  2. Reinstalling docker after cleaning all cache files

Nothing has helped yet. Could someone please help me debug this issue?

I have the same kind of MacBook with the same macOS version so I tried the pull command and worked, although it was a little slower than I expected. I had Docker Desktop v4.16.1 so I updated to v4.16.2, removed the image and pulled again. It was a little faster, but this difference is normal. Your error message can indicate network issue either on your side or on the Docker Hub’s side, but at the moment it worked for me.

I recommend following the Hub Feedback and the Docker System status

If you can’t pull any image (as you mentioned in your first post) and the issue is not temporary check your local network and proxy settings.

1 Like

Hi, thanks a lot for suggesting the network issue. It worked once I moved to personal hotspot. Seems my university network caused the problem.