"https://registry-1.docker.io/v2/": EOF Windows WSL2

Docker desktop (Any version) in Windows Server 2022 and WSL2 (Debian or Ubuntu).
I have spent way too much time trying to resolve this with no success. I am making a new post as none of the others are as specific as this.

Pulling images return some EOF error:

Error response from daemon: Head “https://registry-1.docker.io/v2/library/mongo/manifests/latest”: Get “https://auth.docker.io/token?scope=repository%3Alibrary%2Fmongo%3Apull&service=registry.docker.io”: EOF


“Error response from daemon: Get “https://registry-1.docker.io/v2/”: EOF”

Very rarely the command manages to pull some layers.
I am confident I have tried every single solution suggested in this forum and stackoverflow.
The “Docker login” command returns a similar error.
Self diagnose tool returns no errors and I am not behind any proxy. However, I do run on a VM.
Note that this used to work some time ago. Could it be related to some windows update?
Is there any way to debug this?

Debug info:

This is a community forum where we can’t see reported diagnistic IDs, but I answered a similar question recently in which case the issue was a university network.

Thanks for the response. I have seen that thread, but there is no information on how to identify if there is a network issue. I have tried to disable the windows firewall and to use different DNS. Everything else works on the machine (e.g. git pull), except docker commands. If there is a way to verify the network is set up properly for docker please let me know.