Docker Community Forums

Share and learn in the Docker community.

Docker push times out

docker

(Shailesh Pant) #1

Expected behavior

docker push of a local image to a private secure registry fail with DNS response timeout

Actual behavior

Docker push should pass. Earlier with docker-machin was able to push. Also pure docker on centos and rhel is still able to push to the same repository. Docker pull are still success

Information

OS X: version 10.11.4 (build: 15E65)
Docker.app: version v1.11.1-beta10
Running diagnostic tests:
[OK] docker-cli
[OK] Moby booted
[OK] driver.amd64-linux
[OK] vmnetd
[OK] osxfs
[OK] db
[OK] slirp
[OK] menubar
[OK] environment
[OK] Docker
[OK] VT-x
Docker logs are being collected into /tmp/20160506-131820.tar.gz
Most specific failure is: No error was detected
Your unique id is: 60695787-0BD0-48DC-B0DB-42937451A461

Steps to reproduce the behavior

just try to push a local image to a remote repo. This repo was a secure one and i did login using curl command and copied the output to ~./docker/config.json & to be on safer side copied the same to / .dockercfg but with no sucess.


beta10 DNS issues
(Shailesh Pant) #2

I just figured out that its related to docker not related to this beta itself. I tried on centos with docker 1.11 and the same issue pop ups. I tried downgrading till 1.10.1 but no success.

Finally 1.8.2 version worked for me. Seems something to do with defaulting to v2 registry in versions above 1.8.2. Mine is a v1 registry.