Docker Community Forums

Share and learn in the Docker community.

Docker push to azure conatiner registry exits with EOF

While using docker push containerregistry.azurecr.io the command always exits with an EOF error.

The push refers to repository [containerregistry.azurecr.io/name] 7387f39edda5: Layer already exists f2868d922c36: Layer already exists a1a215f52b02: Pushing [==================================================>] 851d4ecec8fb: Layer already exists e16c226cf2a8: Layer already exists 7fd597d009e4: Pushing [==================================================>] 7c6ab5fb7059: Layer already exists ed271eac23e9: Layer already exists 156ff16f37e4: Retrying in 8 seconds EOF

1 Like

I am also facing the same issue with docker push and docker-compose push. The error is really annoying. The image size is 950MB.
Any help is highly appreciated.
following are the things I tried

  1. Set the max-concurrent-uploads:2
  2. Restarted Docker multiple times
  3. Tried docker push and docker-compose push commands multiple times

environment:
Windows 10 Enterprise, x64
Docker version 20.10.2, build 2291f61

thank you for the info!
nice topic
merchant crypto