Docker Community Forums

Share and learn in the Docker community.

Docker QuickStart Terminal :'nutc': unknown terminal type


(Ckurali) #1

Hello, I installed Docker on Windows 7 PC.

When starting the Terminal, I see below error.

Did anyone face this issue?

Machine default already exists in VirtualBox.
Setting environment variables for machine default…
‘nutc’: unknown terminal type.
Looks like something went wrong… Press any key to continue…

Thanks again for your help


(Email2dgk) #2

Hello Ckurali -

I am also facing this issue when I installed docker on Windows 8.1 Laptop. But, I could make a pull request over the VM which came along with the docker installation.

However, I have installed the same on different windows 8.1 Laptop.

Thanks
Gokul


(Nsfinch) #3

Hi,

I had the same issue and could not find any other solutions posted online so I went to the shell script that is referenced by the Docker Quickstart shortcut (location shown below):

By working through this script, I found that that the ‘clear’ command is causing the problem when called called from the bash shell. To fix this issue, I crudely commented out the clear command in the ‘Finalize’ step of the shell script (start.sh, line 63).

Hope this helps you as well.

-Nolan


(Veggiebook) #4

I have the exact same problem on Windows 7. Commenting out “clear” did not solve the problem. It generates a new error:

bash: cd: /c/Program Files/Docker Toolbox/%HOMEDRIVE%%HOMEPATH%: No such file or directory
Looks like something went wrong in step ‘Finalize’… Press any key to continue…

That makes me wonder if “clear” sets those environment variables.


(Crisbdal) #5

Late to the party here, but for reference of anyone new who runs into this problem on Windows, this appears to be something to do with the TERM terminal environment variable not being correctly set at startup. We encountered this problem several times and solved it by creating a %HOME%\.bash_profile file and setting ‘export TERM=cygwin’. This overwrites the ‘nutc’ being set in the environment and allows startup to proceed normally.


(Jtoledo) #6

I fixed the error by updating the start.sh script mentioned above as follows:

  1. I added the line
    export TERM=cygwin
    right after the line with the “trap” command. This solves the problem with the “clear” line as proposed by crisbdal, so no need to comment it out
  2. I commented out the line with the “cd” command that appears after the ‘echo "For help getting started,…’:
    #cd
    I have Windows 7. I hope this helps.

(Jboneilusibm) #7

Thank you everyone. I modified C:\Program Files\Docker Toolbox\start.sh. Just below the line

export PATH .

I added the line as I do not have cygwin installed. Setting term to cygwin gave same error as nutc setting. But happy to find xterm value works

export TERM=xterm