Docker Community Forums

Share and learn in the Docker community.

Docker for windows missing quick start terminal

I installed the latest version of Docker for windows in my windows 10 machine. It seems the new Docker Desktop toolbox doesn’t contain the Quick start terminal. Every documentation says to check the quick start terminal option at the time of installation. I dont see any option to check that option with the latest Docker toolbox. Is there any way we could install Quick start terminal for windows. Or are there any other alternate to the QS terminal. My objective is to build, tag and push / pull docker images to a gitlab registry. Powershell, command promt doesn’t work because its a windows machine.

Right click on the Docker icon in the notification area, then click on “Quick start guide”.

Hi Rimelek,
Thanks for your response. I tried this earlier, this actually opens the terminal in powershell right ?
Even there the push to docker registry is never working for me. I am getting the error “to use SANs”. I never got such issue when I was working with the quick start terminal.
image

I tried it long ago, so I don’t remember.

Are you saying the quick start guide is not the same as you call quick start terminal? What is this domain anyway? Is it yours? nslookup can’t find it. The trust in certificates can be different in each environment and sometimes it changes in time and some solution becomes deprecated or even unaccepted. You could add a registry to insecure registries or install the certificates on your host

Or… you could try what the messages says and set GODEBUG=x509ignoreCN. I am not sure it would work and even if it would probably you should set it for docker daemon executed by Systemd so I would try the first two if I were you.

Was it really your question or did I misunderstand?